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Welcome . We sincerely hope you enjoy using your PictureWorks product. 

Behind your purchase is a dedicated team of people with over 50 person years invested in designing innovative
software products to meet your needs. PictureWorks Technology, Inc. develops and markets award-winning 
software based on advanced imaging technology. We work to simplify and speed the process of creating exceptional 
pictures and then helping you manage those pictures. Users of scanners, pictures on CD Rom, digital cameras, and
electronic pictures from on-line services can utilize these innovative tools to enhance and manage their pictures
regardless of the original quality or source. 

PictureWorks software products replace complicated tools common in most imaging applications. We provide the
innovative benefit of keeping the complexity of processing, managing, and utilizing pictures behind the screen. Our
software is the unanimous choice of some of the worlds largest manufacturers of digital cameras and scanners, 
earning PictureWorks a ★★★★ rating from Macworld in its first year of release. 

PictureWorks has developed multiple products with one goal in mind, to provide you with the absolute best tools
possible for both business and personal imaging applications.  Add impact to all that you do with the power of 
customized pictures!  To learn more about how PictureWorks Technology can help you, please give us a call at our
toll-free number, 800-303-5400 or 510-855-2001.
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improvement and your ideas and wish list for future enhancements are invaluable to that process. 

We want to hear from you!
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PhotoEnhancer™  from PictureWorks™ lets you quickly and easily view, manage, and enhance 
pictures from your Kodak Digital Science DC 50 camera. To make picture enhancement fast and easy,
PhotoEnhancer offers SmartPix™. With SmartPix, you get the power of sophisticated enhancement
options available at the click of the mouse. Get goof-proof results with the By Example editing 
feature. By Example is a special visual editing mode allowing you to interactively correct the Focus,
Exposure, Brightness, Contrast, and Color Balance of your pictures.  Simply choose the picture you
like the best and PhotoEnhancer does the rest. Fine tune specific areas with retouching tools like
smooth and sharpen. 

First, be sure to fill out and send in your product registration card today. This is used to keep you
up-to-date with valuable product and upgrade information as well as provide authorization for  
technical support assistance. 

You should have the following to successfully run PictureWorks PhotoEnhancer Plus.

• Apple Macintosh computer with 68020 processor or later or Power Macintosh 
computer

•  Macintosh system software version 7.1 or later

•  Minimum of 6 megabytes or 10 megabytes for optimal performance of available 
RAM and 10 megabytes of available hard disk space or 20 plus megabytes for optimal 
performance.

Remember, by using this software you agree to the software license of this product, printed on the
product package. Read the license agreement carefully before using the software.  Please do not copy
the software illegally. If you have multiple computers and would like to arrange a site license, please
give us a call and we can arrange one.

Opening Pictures and Slide Tables

You can open pictures directly into PhotoEnhancer from your Kodak DC 50, or those pictures
saved on your system or another disk drive. Open pictures directly into the editing window to see
them at full view or open a slide table of pictures saved in a folder or from your digital camera for
quick and easy browsing of multiple pictures.  

Supported File Formats

PhotoEnhancer is designed to view standard Windows file formats. PhotoEnhancer opens
TIFF, PICT, EPS, JPEG, and native digital camera file formats for the DC 50. The native file
format is KDC. You can load pictures directly from your digital camera connected to your 
computer or those pictures from a CD ROM or saved on disk. 

Opening a Slide Table

Use a slide table to view multiple pictures quickly for browsing. Choose Open Slide Table
from the File menu to display a slide table of pictures already stored on your system drive,
external drive, Photo CD ROM or floppy disk. 

1 Getting Started
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To create a slide table of pictures from a digital camera, choose View Slides in Camerafrom the Camera
menu. Refer to chapter 6, Connecting to a Digital Camera for more information and instructions.

Use a slide table to:

• View important picture information

• Change the file name

• Sort slides

• Apply picture corrections

• Print multiple pictures

• Open pictures in an editing window

Opening an Editing Window

Open pictures in an editing window to view them at full resolution and apply corrections with 
freehand tools and menu commands. Open a picture from a slide table by double-clicking its slide or
choose Open from the File menu to select a picture stored on your system, a CD ROM, or another drive. 

In an editing window you can:

• Use selection tools and enhancement brushes from the tool palette

• Cut, copy, paste, and crop pictures

• Use the By Example editing mode to visually and intuitively apply corrections 

• Apply SmartPix picture corrections

• Rotate, flip, and resize pictures

• Print individual pictures



This chapter describes the concept of a slide table, how to work with the slides, and browse pictures that are
located in a folder, all from a slide table window.

Understanding Slide Tables

You can look at multiple pictures that are located in a folder all at one time in a single window called a slide
table. The pictures in a slide table are miniature representations of the original pictures stored in a folder saved
on your hard drive or those stored on your DC 50. These miniature pictures are called thumbnails. 

Use the slides to display and select multiple pictures at one time, view important file information, apply 
picture corrections, and open pictures to display in full resolution.

Opening a Slide Table

Choose Open Slide Tablefrom the File menu to select the folder of pictures you want to display.  To create a slide
table of pictures from a digital camera, choose View Slides in Camerafrom the Camera menu. Refer to chapter 6,
Connecting to a Digital Camera for more information and instructions.

To open a slide table of pictures saved in a folder:

1. Choose Open Slide Table from the File menu. The Open Slide Table dialog box appears.

2. Select the drive that contains the folder of pictures you want to display in the slide table. 

3. Click once on the folder that contains the pictures you want to display.

4. Click OK. Available picture files appear in the dialog box. File names appear grayed as 
you cannot select individual picture files to open from this dialog box. 

5. Click Select Folder to display all pictures in the folder in a slide table window. All pictures saved in one 
of the supported file format are opened. 

Creating a Slide

Pictures from other applications may not have a preview to display on the slide table. You can still open these
pictures at full resolution and get information, without a picture preview. However, you can also create a slide
thumbnail to display on the slide table. To create a slide thumbnail, choose Create Slidefrom the Picture menu.
When you close the slide table window, slide thumbnails are always saved with TIFF files for future use. Slide
thumbnails are not saved with pictures stored in any other file formats. 

Sorting the Slides

To help you work with the slides in a slide table, you can sort them by file name and creation date. To sort the
slides in the slide table choose Sort by, then choose Sort by Nameor Sort by Datefrom the Picture menu.    

2 Using Slide Tables
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Changing the Picture Name

You can change the picture file name directly from a slide table. The picture name displayed on the slide and
the file name stored on disk update accordingly.

To change the picture name from a slide table:

1. Position the cursor over the picture name you want to change. 

2. Click once to highlight it. 

3. Enter the text for the new file name. 

4. Click outside of the text string or press Return to accept the name and update 
the file name on disk. 

Getting More Information About A Picture

Choose Get Infofrom the File menu to display important and specific information about pictures in a slide
table. A slide must first be selected to use the command. If multiple slides are selected, a Get Info dialog box
appears for each picture. 

Applying Enhancements in a Slide Table

Use the slide table to apply corrections to multiple pictures at the same time without having to open the 
picture(s) into an editing window. This is also useful to test different enhancements to the same picture since
you will first save the pictures and can rename the file or save it to a different location, leaving the original 
picture unchanged. Enhance and SmartPix menu filters are not available with black and white pictures or those 

converted to the 256 System or 256 Custom color depths. 

To apply a correction to a picture on a slide table:

1. Select the slide of the picture you want to correct by clicking on it once. Hold the Shift key 
first and then click to select multiple slides for corrections. 

2. Choose the correction you want to apply from the Enhance or SmartPix menus, for example 
Daylight Bright.
The Save As dialog box appears for you to save a copy of the picture to a new folder or choose to

overwrite the original file.  

3. Click Save/OK.

Closing Pictures and Slide Tables

When you are finished working with pictures in an editing window or slide table, choose Closefrom the File
menu or click the Closebox in the upper left corner of the window. If the picture has not been saved, a prompt
appears asking if you want to save it.  

When working with multiple open windows, use a quick key combination to close all of them at one time.

To close multiple windows at one time:

1. Place the cursor over the Close box of one of the windows.

2.  Hold the OptionKey first key and then click the box.

All open windows close. If any pictures have not been saved, a prompt appears asking if you want to save it. 
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This chapter describes how to open pictures from a slide table or directly from disk for enhancement.  

Opening Pictures for Editing

There are three places from which to open pictures for editing:  from the hard disk or another storage medium
or from a slide table. 

To open your digital camera pictures into an editing window, first create a slide table view of the pictures in
your camera. Next, double-click the slide of the camera picture you want to open. Refer to Chapter 6,
Connecting To A Digital Camera , for more information and instructions. 

Using the Open Command

Choose Openfrom the File menu to open single pictures saved on your computer system, external
drive, CD ROM, or floppy disk. 

Using Mactintosh Drag-and-Drop to Open Pictures

You can use drag-and-drop to open pictures into an editing window without having to manually
open the PhotoEnhancer application.

To open a picture using the Macintosh drag-and-drop method:

1.  From the Macintosh desktop, locate the PhotoEnhancer application icon.

2.  Locate the picture file you want to open.

3.  Click and drag the picture file icon over the PhotoEnhancer icon.

4.  When the PhotoEnhancer icon darkens, release the mouse button.

The application launches and the picture opens in an editng window ready for enhancements.

Opening Pictures from a Slide Table 

To open a picture from a slide table, double-click on the slide. If multiple slides are selected when the
double-click is initiated, each picture opens in a separate editing window.

To open multiple pictures from the slide table:

1. From the Slide Table window, hold the Shift key and click on each slide that you want to 
open. 

2. Choose Open Selected Slides from the File menu or simply double-click on one slide. 

Each picture is opened, at full resolution, in a separate editing window ready for enhancement. 

Choosing a Color Depth

The Color Depth command lets you change the bit depth or number of colors in the editing window. You can
reduce the color information of your picture anywhere from Millions of Color (representing a full 24 bits of
color) to Thousands, down to 256 shades of gray, thus reducing the amount of picture data and the size of the
file on disk. 

Opening Pictures 
for Editing

3



Choose from one of the following pre-determined color depths.

Millions of Colors 24 bit color picture

Thousands of Colors 16 bit color picture

256 System Colors 8 bit color picture converted down using the 
default system color palette 

256 Custom Colors 8 bit color picture using a sampling of the 
colors from the original picture

256 Shades of Gray 8 bit grayscale picture

16  Shades of Gray 4 bit grayscale picture

Black and White 1 bit black and white picture

Some enhancement filters are not available when working with black and white, 256 System and Custom color
depths. To use these filters, temporarily convert your picture to another color depth. 
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With PhotoEnhancer you can isolate your edits to a specific part of a picture so other areas are not affected by
retouching. The protected area of the picture is the area outside of a selection. The picture area that is not
masked, and will be enhanced, is the area inside the selection. A picture must be open in an editing window to
use the selection tools. 

Masks are created when you use any of the Selection tools — Rectangle, Polygon, Lasso, and Magic Wand. 
The selected area can be:

• Modified using the brushes on the tool palette

• Cut, copied, cleared, or cropped

• Modified using other PhotoEnhancer picture correction commands

Adding to Selections

The Shift key allows PhotoEnhancer to select another area of the picture without cancelling any existing 
selections. Hold the Shift keyand drag around another portion of the picture and add it to the current selection.  

Cancelling Selections

To cancel a selection, click outside of the selection with either the Rectangle or Lasso selection tools or choose
Select Nonefrom the Edit menu. 

Hold the Shift and Option keys and drag around the area that you want to deselect and add it to the masked
area without canceling other areas. Any of the selection tools can be used to deselect portions of a selection. 

To deselect a portion of a selection:

1. Choose the desired selection tool from the tool palette.

2. Place the cursor over the area of the selection you want to deselect. 

3. Hold the Shift and Optionkeys and press the mouse button.

4. Drag the mouse around the area of the selection that you want to deselect. 

5. Release the mouse button. 

Deselected areas are added to the mask and are protected from further edits.    

Using the Selection Tools

To use the selection tools, click the icon of the one you want from the tool palette.  

Rectangle

Use to create square or rectangular shaped selections. 

Polygon

Use to create irregularly shaped selections in line segments. 

4 Creating and Working 
with Selections
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Lasso

Use to create irregular shaped selections with freehand curves. 

Magic Wand

Use to automatically create a selection based on colors picked up from the picture. To use the Magic
Wand click and drag the tool over the colors you want to select. 

To select an area with the Rectangle tool:

1. Choose the Rectangle selection tool from the tool palette. 

2. Position the cursor to anchor a corner of the desired selection area. 

3. Click and drag the mouse to define the area for selection. 

4. Release the mouse button to complete the selection.

To select an area with the Polygon Selection tool :

1. Choose the Polygon selection tool from the tool palette. 

2. Position the cursor on one corner of the area that you want to select and click to anchor the 
polygon. 

3. Move the cursor to where you want the next corner and click. A selection line is drawn 
between the first and second points. 

4. Move to the next point and click. Continue until your picture is outlined and selection
complete. 

5. When finished, double-click. If the last and first points are not connected, a straight line is 
drawn between them.  

To select an area with the Lasso Selection tool :

1. Choose the Lasso tool from the tool palette. 

2. Position the cursor where you want to begin the selection. 

3. Click and hold the mouse button. 

4. Drag the mouse to outline the desired area.

5. Release the mouse button to complete the selection. 

If the last and first points are not connected, a straight line is drawn between them. 

To select an area with the Magic Wand Selection tool :

1. Choose the Magic Wand Selection tool from the tool palette. 

2. Position the cursor over the colors you want to select. 

3. Click and drag the mouse over all the colors you want to include in the selection. 

4. Release the mouse button to complete the selection. 
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When you release the mouse button, the Magic Wand searches outward until it detects colors that

were not initially selected, thus defining the edge of the selection area. 

Working with Selections

The Edit menu contains commands to move, duplicate, delete and crop selected areas of the picture. The Undo
and Redocommands can be used to reverse the last action. 

Before an area can be cut, copied, or cropped, it must be selected with one of the selection tools. If more than
one area is selected, the commands affect all of the areas. 

Cut

Removes the selected area and places it in the system Clipboard. This creates an empty area in the 
picture. The cut area can be pasted into the same picture, another open picture, or another application. A
selection must first be made to use the Cut command. 

Copy 

Places a copy of the selected area in the Clipboard without removing it from the picture. The copied
area can be pasted into the same picture, another open picture, or another application. A selection must
first be made to use the Copy command.

Paste
Pastes the Clipboard contents into the current picture. Drag the object where you want it located. To use
the paste command, you must first cut or copy a portion of an picture.

To paste the clipboard contents:

1. Choose Paste from the Edit menu. 

2. Drag the pasted selection to a new location. 

3. Click once outside the selection to anchor it in position. 

Crop

To use only a portion of an picture, you can crop the picture and discard unwanted areas. This reduces
the picture size and the amount of disk space required. The area outside the selected area is discarded
and the picture window shrinks in around the remaining part of the picture. 

U S I N G M A S K S A N D S E L E C T I O N S



5 Enhancing Pictures
This chapter discusses using SmartPix™ filters to correct lighting condition, By Example editing, using freehand

tools, and advanced imaging controls. It also describes applying filters while working in an editing window as well
as from a slide table. 

Using the Enhancement Brushes

Enhancement tools let you make freehand enhancements. Brushes include Sharpen, Smooth, Lighten, and
Darken. Remember, a picture must be open, and active, in an editing window to use the PhotoEnhancer tool
palette. Choose Undofrom the Edit menu to delete changes made with the enhancement brushes, so feel free to
experiment with the different brushes. Redoreverses the undo and returns the enhancement to the picture. 

A picture must be open in an editing window for the tool palette to be available. To use one of the tools, click the
appropriate icon from the tool palette.

Hand 

Use to move the picture so areas that do not fit in the window can be viewed. Click and drag on the 

picture until the area you want to use is visible within the window.

Zoom

Use to quickly increase or decrease the magnification of your picture by twice its size each time the
mouse button is clicked. To zoom in, simply click the mouse button. To zoom out, hold the Option key and
click the mouse button on the Windows and click the Right mouse button in Windows. 

Sharpen

Use to sharpen and add emphasis to the blurred areas of your picture. 

Smooth

Use to apply a heavy blur or hazy effect to your picture. 

Lighten

Use to add highlights to the dark shadows in a picture. 

Darken

Use to add shadows to bright or hot spots in a picture. 
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Applying Enhancements in a Slide Table

Use the slide table to apply corrections to multiple pictures at the same time without having to open the 
picture(s) into an editing window. This is also useful to test different enhancements to the same picture since you
will first save the pictures and can rename the file or save it to a different location, leaving the original picture
unchanged. Enhance and SmartPix menu filters are not available with black and white pictures or those 
converted to the 256 System or 256 Custom color depths. 

To apply a correction to a picture on a slide table:

1. Select the slide of the picture you want to correct by clicking on it once. Hold the Shift key 
and click to select multiple slides for corrections. 

2. Choose the correction you want to apply from the Enhance or SmartPix menus, for example 
Daylight Bright.
The Save As dialog box appears for you to save a copy of the picture to a new folder

or choose to overwrite the original file.  

3. Click Save/OK.

Using SmartPix™

SmartPix™ menu enhancements eliminate guessing when correcting for picture conditions such as dark 
shadows and flat colors. Simply choose the SmartPix that best describes your picture. Experiment with the 
different SmartPix to find the best one that corrects for your picture condition.

You can apply SmartPix to a picture in an editing window or directly to a picture on the slide table; you don’t
even have to open the picture.  Refer to Applying Enhancements in the Slide Tablesection previously in this chapter
for steps to enhancing pictures in a slide table. 

Choose Undo/Redofrom the Edit menu when working with picture corrections so you can experiment with the
different settings. SmartPix are not available with black and white pictures or those converted to the 256 System
or 256 Custom color depths. 

All SmartPix are available in two settings: Faster and Better.

Faster Choose Fasterfor a lighter setting of the correction. 

Better Choose Better for a more intense application of the correction.

Daylight Bright

Use to correct pictures taken in bright sunlight where shadows may be washed out. 
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Daylight Cloudy

Use to correct pictures taken on a hazy, overcast or cloudy day.

Light Shadows

Use to lighten the slightly darker or shadow areas of your picture. Shadows can be generated on
bright, sunny days so you might want to try this SmartPix with many different pictures.

Heavy Shadows

Use to lighten the darker or heavily shadowed areas of your picture. 

Inside

Use to correct for low indoor lighting.

Inside Flash

Use to correct pictures that have been over exposed by a direct flash on your subject. 

Fluorescent

Use to correct for the undesirable effect that occurs from indoor lighting. The effect is recognized by
the green or yellow cast washed over a picture. 

Using the Picture Correction Commands

The Enhance menu contains additional commands to apply corrections to pictures. To apply a correction,
highlight the filter name from the menu or submenus. Use the commands to soften, sharpen, intensify colors,
lighten shadows or adjust the picture values.   

Last Filter

The last correction applied to your picture is listed at the top of the Enhance menu. Use the keyboard
short cut Command/Control-Fto save time when applying the same correction to multiple pictures.

Adjust

The Enhance and Adjust sub-menus contain commands to modify the values in the picture. Open a
picture into an editing window for corrections or select multiple slides from a slide table for batch 
processing. To apply a correction, highlight the filter name from the Adjust submenu. For example
choose Intensifyto bring out detail and increase contrast of flat, drab pictures.

E N H A N C I N G P I C T U R E S
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Editing By Example

By Example is a special visual editing mode for interactively correcting Focus, Exposure, Brightness/Contrast,
and Color Balance. Different settings of the corrections are applied to nine samples of the picture. 

Using By Example Corrections within a Selection

By Example corrections can be isolated to a selected area. Use the Selection tools to select the area that
will be effected by changes before choosing By Example from the Enhance menu. 

Picture Preview

A reduced version of the original picture appears in the upper right corner and contains a small blue
square of a fixed size. The square is used to identify the portion of the picture that is viewed in the
sample boxes. This same area appears in each of the sample boxes so you can evaluate the effects of the
different choices against a consistent background. 

The square only controls what part of the picture appears in the sample boxes; it does not isolate the
effects to that area. Drag the square at any time during a session to view the effects on different parts of
the picture. 

Working with the Samples

Of the nine samples, the center box in the middle row always represents the current picture.  The 
currently selected sample box is highlighted by a blue outline. To select a new sample, double-click on it
once. When you apply the setting, nine new samples are generated based on the new enhanced picture.
To apply the setting to the picture, click the Applybutton or simply double-click on any of the samples. 

There are four buttons to help you work and test the different corrections. Use the buttons to perform
the following functions:

Undo Deletes the last change applied to the picture

Revert Returns the picture to its original state saved on disk

Done Exits By Example and returns you to the editing window

Apply Updates the preview picture to the currently selected correction and generates 
nine new samples 

To edit By Example:

1. Choose By Examplefrom the Enhance menu.

2. Click the button next to the picture correction you want to use, for example Exposure.

3. Drag the square in the picture preview to select the portion of the picture to be displayed in 
the sample boxes. The square can be moved at any time during a session to view a different 
area of the picture. 

4. Choose a variation level to adjust the level of intensity between effects applied to the samples, 
for example Mediumor Fine.

5. With the Color picture correction, choose the colors you wish to add or subtract from the 
picture, for example Magenta/Greenor Yellow/Blue.
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6. To select the corrected picture you like, click the appropriate sample box. 

7. Click Applyor double-click on the desired sample to apply it to the picture. The preview 
picture updates and PhotoEnhancer generates nine new samples.  

8. When you are satisfied with your picture and finished with By Example editing, click Done. 

Variations

Use the Variations drop-down menu to set the increment of change between the nine samples.
Variation increments are Fine, Medium Fine, Medium, Medium Coarse, and Coarse.

Highlight the desired variation from the pop-up menu to choose that setting. For example, choose
Fine to view very little difference between the examples or choose Coarsefor a change that is more
obvious. 

Variation levels are available with Brightness/Contrast, Color, and Focus picture corrections. Variation
levels are not available with the Exposure picture correction. 

Picture Corrections

Click the button by the correction that you want to use. The sample boxes are updated to display the
correction in the selected variation. Choose from Focus, Exposure, Brightness/Contrast,or Color Balance.

Other Picture Changes

This section explains the commands used to modify the orientation and size (scale) of a picture. It also explains
changing color depth. 

Using the Flip Commands

Use the Flip commands to transform a picture while working in an editing window. Flip the entire
picture or only a selected area. Flip commands are not available while working in a slide table. 

Flip Vertical
Choose to flip the picture or selected area from bottom to top (180 degrees). 

Flip Horizontal
Choose to flip the picture or selected area from left to right (180 degrees).

E N H A N C I N G P I C T U R E S
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Using the Rotate Commands

Use the Rotate commands to change the orientation of camera pictures in a slide table or a picture in
an editing window. Rotate the entire picture in the editing window or only a selected area. 

90 Degrees Right
Choose to rotate the picture, selected area, or camera slide clockwise 90 degrees.

90 Degrees Left
Choose to rotate the picture, selected area, or camera slide counter-clockwise 90 degrees.

180 Degrees 
Choose to rotate the picture, selected area, or camera slide 100 degrees.

Using the Resize Command

Choose Resizeto change the picture resolution and overall size. Changes made in the Resize dialog box affect
the entire picture in the editing window. Resize options are not available while working in a slide table. By
changing the resolution of a picture you will also change the size, and vice versa. Lower resolution pictures
require less disk space to store than higher resolution pictures. Notice the original picture resolution and size
listed in the dialog box. 

To resize a picture:

1. Choose Resize from the Image menu.

2. Choose the units of measurement you want from the drop-down menu. 

3. Enter the new values for width, height, and resolution. When you change any of the resize 
values, PhotoEnhancer automatically updates the other values to maintain the current 
picture proportions.

4. Click OK when you have set the desired dimensions. 



This chapter describes using the commands in the Camera menu to open, view, and take pictures with your
Kodak Digital Science DC 50. It also briefly reviews the camera controls that are available for your digital 
camera directly from PhotoEnhancer. Refer to the documentation provided with your camera for more in depth
descriptions and instructions. 

To use the PhotoEnhancer Camera menu commands, the camera must first be connected to the computer and
turned on. Refer to the documentation provided with your DC 50 for directions on choosing ports and setting-
up the camera connections.  

Setting Camera Preferences

Choose Preferences from the Edit menu to configure PhotoEnhancer to which port your digital camera is 
connected. By default PhotoEnhancer is set to look for the DC 50 on an Auto Search. This tells PhotoEnhancer to
search all of the ports to locate your camera.    

Viewing Pictures From the Camera

Choose View Slides in Camerafrom the Camera menu to display the pictures currently in the camera as slides
in a slide table.  A dialog box appears so you can select to view the pictures stored on the camera or PCMCIA
card and the range of pictures that you would like to open. Say for example, that you know that any one of the
last five pictures you took that day are going to be the best shot of all thirty-six pictures in your camera.  Click
the From option and type in 31 to 36 in the text edit box and instruct PhotoEnhancer to open only those pictures.
The five pictures open in a new slide table window.

Remember, the camera must be connected to the computer and turned on or this command is grayed out.

Saving Camera Pictures To Disk

Choose Move All Camera Pictures to Diskfrom the Camera menu to transfer pictures from the camera to your
hard drive. A dialog box appears so you can choose to move pictures from the camera or the PCMCIA card and
the range of pictures that you would like to save. Next, the Save As dialog box appears, select the folder and
drive to save your pictures to.  

Setting the Camera Name 

Choose Set Camera Namefrom the Camera menu to personalize your camera. A dialog box appears for you to
enter your own unique camera name. You can enter a name up to 26 characters. This is especially helpful if more
than one camera transfers pictures to a particular computer. Remember, the camera must be connected to the
computer and turned on or this command is grayed out. 

Connecting to the 
Kodak DC 506
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Setting the Camera Date & Time

Choose Set Camera Date & Timefrom the Camera menu to update the camera clock to match that of your 
computer system.  A dialog box appears to indicate that the camera date and time need to be reset. If it does,
click OK.  Remember, the camera must be connected to the computer and turned on or this command is 
grayed out.

Using the Camera Controls

Use the camera controls in PhotoEnhancer to set the flash, exposure, picture quality, set zoom and focus
points, view the battery level, and take pictures without leaving the application. Remember, the camera must be
connected to the computer and turned on or this command is grayed out. For more in depth instructions and
descriptions to using the camera controls, refer to the documentation provided with your camera. 

To change the settings, simply click on the control icons. Hold the mouse button and drag through the options
displayed graphically.  The selected setting is indicated by a highlight square. All camera settings, with the
exception of Quality, return to default when the camera is turned off. 

Take a Picture 

Click the blue, Take Picture button to take a picture with the camera connected to your computer. The
picture automatically appears in a PhotoEnhancer slide table. If a slide table is not open, a new slide
table is created. 

Sleep Time out

Use the Sleep Time out options so when you are not using your camera, and it is connected to your
computer, PhotoEnhancer automatically turns the camera off to conserve energy and battery power.
Choose to have the camera shut down in 1, 2 or 4 minutes from the drop-down menu.  

Flash

Click to toggle between the three flash settings.

To let the camera’s light sensor determine when to flash. 

For a flash with every picture. 

To turn off the flash. 
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Picture Quality

Use the Picture Quality controls to set the camera to take a low, smaller “snap shot”, medium or
highest quality picture. The actual picture resolution does not change between the different settings, but

rather stays the same at 144 dots per inch (dpi).  What changes is the picture dimension and amount of
disk space to store the picture. 

Select the smaller, Goodquality pictures when you are running low on disk space and need to 
conserve. 

Battery Level 

The battery icon is full (red) when the batteries are fully charged, half full to show that they are
running low, and empty, and blinking, when they need to be recharged or replaced. 

Refer to your QuickTake User’s Guidefor information about battery care. 

Timed Shutter

The Timed Shutter gives you 10 seconds before the camera automatically takes a picture. Choose
between the two options to turn the option on or off. 

Exposure

As in traditional photography, use the Exposure controls to adjust the camera to allow more light in to
expose the film. Increase the exposure if taking pictures in dark or low lighting, decrease exposure when
taking pictures in bright sunlight. 

To change the settings, simply click on the Exposure icon. Hold the mouse button and drag through
the options displayed graphically.
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Good Quality Best Quality

Better Quality

timed shutter off timed shutter on

least amount of light exposed to film 

most amount of light exposed to film 



Zoom 

Use the Zoom controls to set the lens length on the camera.  Choose to take a picture at close range and
focus on one subject or further out for a more wide angle view. These controls work the same as using the
Telephoto and Wide Angle buttons on the camera. 

To change the settings, simply click on the Zoom icon. Hold the mouse button and drag through the
options displayed graphically.

Focus

Use the Focus controls to set the focal point of the camera.  Choose multi-point, single point or close up
focus. 

To change the settings, simply click on the Focus icon. Hold the mouse button and drag through the
options displayed graphically.

Camera Utility

The camera utility is a floating palette offering you constant, updated information and connection with
the pictures in your camera.  Use the palette to view the pictures taken and remaining on the camera and
PCMCIAcard, move pictures to the hard disk or PCMCIA card, view pictures in a slide table, and erase
pictures. 

To use the options, simply click on the graphical icon.  The Camera Utility control works as a toggle;
choose Show Camera Utilityfrom the Camera menu to view the palette. When the palette is open, the
menu command name changes. Choose Hide Camera Utility  from the Camera menu to close the palette. 

C O N N E C T I N G T O A C A M E R A
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PhotoEnhancer saves pictures in standard Windows file formats including TIFF, JPEG, BMP, and the native
format for the camera, KDC. When saving pictures, select a file format that best suits your particular project.  

Saving Pictures 

Choose Save Asor Save Allfrom the File menu to save a single, selected few or all pictures from a slide table.
Or, you can save a picture from the Editing window. From the dialog box choose a folder and hard drive and
select the desired file format and color depth in which to save your pictures. To save a copy of a single picture
in the same folder as the current slide table, enter a new picture name. Choose Save from the File menu to 
overwrite the original picture file on disk. 

To save pictures from a slide table or editing window:

1. If saving from a Slide Table, click once on the picture you want to save. 

Hold the Shift key and click to save multiple pictures at one time. 

2. Choose Save Asfrom the File menu. The Save As dialog box appears. 

3. Locate the folder and drive where you want to save your picture.

4. When saving a single picture enter a new file name if desired. 

5. Click Save. The picture is saved and the original picture remains, unchanged, in thecurrent slide table 
or editing window.

To save all pictures from a slide table:

1. Choose Save Allfrom the File menu. The Save All dialog box opens.

2. Locate the folder and drive where you want to save your picture.   

3. Choose a file format and color depth from the pop-up menus. 

4. Click Save.   

7 Saving and Printing

Save As dialog in Windows
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Printing Pictures

PhotoEnhancer prints single or multiple pictures as slides or in full resolution. This section describes the steps
to printing. 

Printing from a Slide Table

When printing from a slide table, all the pictures are printed as you see them on the screen; multiple
slides on a single page. 

To print from a slide table:

1. Choose Print from the File menu. The Print dialog box opens.

2. Select the attributes that you want to apply to your page. 

3. Click Print in the Print dialog box to print the slide table. 

Printing from an Editing Window

When printing from an editing window the picture is printed in full view.

To print from an editing window:

1. Choose Print from the File menu. The Print Options dialog box opens.

2. Select the attributes that you want to apply to your page. 

3. Click Print in the Print Options dialog box to print the picture. 



anti-aliased : A subtle technique for smoothing
jagged edges.

bilevel :  Two color picture (black and white).

bit : (Binary digit.) The smallest unit of
information your computer uses.  It is expressed as
1 or 0, meaning on or off, yes or no, positive or
negative, something or nothing.  Eight bits are
required to store one alphabet character.

bit depth :  The number of bits used to define a
devices capacity to reproduce grays or colors the
greater the bit depth (e.g. 32-bit), the more colors
you will have available.  Pictures are also defined in
terms of bit depth (e.g. 24 bit image).

BMP : A standard file format called a bit map.
An image formed by a rectangle grid of pixels. A bit
map is the set of bits that represent the position and
binary state of a corresponding set of items to form
a bit image such as your display screen.

brightness :  One of the three dimensions of
color; the other two are hue and saturation. The
term is used to describe the intensity of light 
reflected from or transmitted through a picture
independent of hue or saturation.

button : Any control you can click which allows
you to designate, confirm, or cancel an action

By Example : A unique editing feature by
PictureWorks Technology, Inc., that provides on-
screen visual choices to correct for problems 
common in picture-taking, such as exposure, 
brightness and contrast. By Example then gives
examples of editing corrections, the user simple
selects the best one.

By Example dialog : A dialog to interactively
choose the best enhancements for your photos.

camera connection :  The physical connection
between your camera and your computer.

camera ID :  The identification of a camera in
name or number reference.

Glossary
clipboard :  The applications for holding the last item
that you cut or copied.  Such items can subsequently be
pasted into an appropriate place or document.  Each
process of cutting or copying deletes the previous item
from the Clipboard. Show Clipboard.

coarse:  Halftone screen with a ruling of less than 
133 lpi.

contrast:  The tonal graduation between the high-
lights, midtones, and shadows in an picture.

crop:  To trim or mask an illustration so that it fits a
given area or discard unwanted portions.

custom palette : A grouping of colors, defined from a
specific picture.

decompress :  Restoring a compressed picture to its
full file size.

dimensions : Any measurable extent, as length,
width and often depth; scope.

directories :  Catalogs of information about files on a
disk. Storing groups of files in different directories
makes files easier to use. Like files, directories can be
created by you or an application.

disk : A circular platter coated with a magnetic 
medium on which a computer data is stored. Disks 
may be rigid or flexible and may be permanently
installed in your computer, in a peripheral device or 
in removable cases.

dpi: Dots per inch. 

enhance :  To make greater, heighten, to improve.

EPS/F: (Encapsulated PostScript File) A graphic file
format used to transfer PostScript picture information
between applications. 

equalize :  To make the same quality, size, value etc..
To make equal or uniform.

exposure:  The step in photographic processes during
which light produces the picture on light sensitive 
coating.

faded :  To lose color, intensity, power etc.
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fine : A halftone screen with a ruling of more
than 150 lip.

flip :  to turn or to turn over.

fluorescent light :  Light produced by glass
tubes coated on the inside with a fluorescent
substance that gives off light when acted upon by
radiant energy.

focus :  The adjustment to create a clear, sharp
picture.

font : A complete assortment of letters, numbers,
punctuation marks, etc. of a given size and design.

get info :  (File Menu)  Invoking this command,
having first selected a folder or file, produces a
window that gives you information about that
folder or file.

grayscale image :  The depiction of gray tones,
ranging from white to black.

halftone :  The pattern of different sized dots
used to simulate a continuous-tone photograph,
either in color or black and white.

hue:  The color family or color name used to
refer to color; e.g., green or red.

icons : A graphic representation of an object,
such as a disk, file, folder or tool or of a concept or
message.

image : A representation of a person or a thing;
a picture or photograph.

image depth :  The number of colors available
to build a color palette.  The more colors in a 
picture, the better the quality.

intensify :  To become or make more intense; to
make stronger increasing the amount of force,
light, etc..

JPEG:  (Joint Photographic Experts Group) A
data compression standard.

Kodak Digital Science DC 50 : A digital 
camera manufactured by the Eastman Kodak
Company.

KDC: A native file format to the Kodak Digital
Science camera.

lighten :  To decrease the degree of brightness or
darkness of a picture, regardless of its hue or 
saturation.

lpi :  (lines per inch)  The number of horizontal and 
vertical lines in a linear inch. Halftone screens are
measured in lines per inch, which represents rows of
halftone dots per linear inch.

mag:  Magenta; the special shade of red that is one of
the four color process color inks. It reflects or transmits
blue and red light and absorbs green light.

mask :  The inactive, or protected, area of a picture that
will not respond to changes.

negate :  To invert an original picture so as to appear as
a negative where the values of the original are reversed so
that the dark areas appear light and vice versa.

paste:  The command that copies an item on the
Clipboard and places it in a document.

PICT :  abb:  picture.  A standard file format for 
storing object-oriented pictures.

pixel :  (picture element) Each of the dots that make up a
computerized picture. It is the smallest picture sample that
can be sensed, manipulated, or output by a digital system. 

In a color system each pixel is represented by either a
COMIC or RGB value.

redo: A standard command, which allows you to repeat
or do a step over.

resolution :  The degree of precision - the quality,
definition, or clarity - with which a picture is represented
or displayed, such as by a scanner, monitor, printer or
other output device.

revert:  To go back or return.

rotate:  To turn around an axis.

set:  In traditional type design, the width of an 
individual character.  The width or set, of the widest 
character is measured in points. 

sharpen :  The process of making the edges of an object
in a picture more apparent.

shadow:  The darkest part of an picture, represented in
a halftone by the largest dots.

slide : A photographic term used to describe a single
frame of film, or a single picture from a digital camera or
other input device or hard drive.

slide table : A grouping of slides.

SmartPix : A feature which provides custom built-in
corrections for a wide range of lighting conditions that
can negatively effect picture quality.



25

G L O S S A R Y

smooth :  The refinement of bitmapped pictures by
rounding off the corners of the square dots, or pixels.

soften :  The process of making the edges of an
object in a picture less apparent.

standard resolution :  The default resolution used
in many devices such as monitors and printers in Mac
and Windows operating systems.

system : A complete set of connected things,
organized to achieve an objective.

TIFF :  (Tagged Image File Format)  A standard file
format that is commonly used for digital pictures.
TIFF can handle a variety of picture data, from 1-bit
black-and-white pictures to 24-bit color RGB or
CMYK.

undo: A standard command, found in most
applications, that allows you to revert to the last text
or format change.

variations : The amount of change overall between
two items.

zoom in :  To increase magnification. Frequently
used to focus on details of an picture.

zoom out :  To decrease magnification. Frequently
used so you can see an entire picture.
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