Check List

For Lab Users

. Check the desk top of your computer. If you see an icon for a floppy disk from a
previous user, tell a lab assistant or move to another computer.

. Find the student folder located on the desk top. Open the folder, drag all of the contents
to the trash icon on the desktop, and select “Empty Trash” from the Special Menu.
Then close the student folder.

Special

Clean Up Desktop

Empty Trash... .
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Eject Disk

Restart
Shut Down

. Go to the finder menu and quit all running applications except for Finder, DarkSide,
and Launcher.

* You quit applications by select them within the finder, and then selecting “Quit”

from the File menu. Edit
« (DL Nei% EN |

Hide Finder Open... #®0
Hide Others

DarkSide

« [ Finder
W3 HTML Editor 1.1
W Netscape 2.0b3
# PowerPoint

Quit 0

. Go to the Launcher to start the session!

For Everyone
. Check your e-mail using Eudora and check for messages and class announcements.

. Log into our class using Netscape and proceed to the lectures, exercises and
assignments.

. Contribute!!!
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Using Netscape

. To start Netscape, go to the launcher and double click on the
Netscape Icon.

. If Netscape is already running, you will see the Netscape
icon in the upper right-hand corner of the computer monitor.

Iﬂ[lﬂl Uinii  && Book

Dpen Lecation— L

In this case, you should go to the “file” menu and click on QD e et

“New Window.” R '
Pagi Saies...
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Quilt ]

. The start-up page for Netscape often looks like this......
twi'sBew? | whes 0T | Hesbeok | PabkSesrsh | et Drestes | Sofuers |
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. You can move to new locations by clicking once on

highlighted text. Pictures will also sometimes serve as -

. . , (4 SPORTS

links to new locations. You know when you've /  INFORMATION

encountered a “link” because the pointer will turn to a e

hand.

. You can also go back to pages you've visited during a given session by using the
“Go” button at the very topic of the computer screen or by using the menu bars
on the top of the Netscape browser.
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To OPEN A NEW LOCATION, you can either click on “Open Location” within the File
menu, or you can click on “Open” at the top of the Netscape browser.

it Mol Docesl... L
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In either case, you will then see a window titled “Open Location.” Type in the address
(URL) of the location where you want to go, and then click “Open.” Here I've typed in

the address for our class.

Open Location

Open Location:

http://www.cyber.vt.edu/mbo/

If you come upon a page you like, you can always SAVE A BOOKMARK for the page

SO you can return easily.

In our class, you can also send mail, enter a chat, or post messages by filling out forms

within Netscape.

T WS W W
Message Entry Form
TEEN, WL, W W

Waxrs
Subject |
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Adobe Acrobat From within Netscape

Many documents available on the World Wide Web are written in a language called
HTML. However, different types of documents can be accessed through the Internet.
One type of document that we will use frequently in this class is called a PDF document.
These documents are written in any type of software and converted into PDF files
through the use of a program called Adobe Acrobat. Once converted, these documents
can be accessed through Netscape. Adobe Acrobat documents (or PDF documents)
usually end with the extension pdf. For example, our first lecture is called “areas.pdf.”

To read PDF documents, Adobe software must be installed on the computer, and
Netscape must be correctly configured to use this software. Most of the labs at Virginia
Tech are correctly configured for this purpose. If you intend to use your own computer to
access course materials, you can obtain a free copy of Adobe Acrobat Reader and install
it on your machine. The software and instructions for configuration can be found at this
address: http://reserve.lib.vt.edu/software.html

Once Adobe Acrobat is correctly installed, you can access
PDF documents by clicking on a link from within Netscape.
Sometimes it takes a few moments for the document to
load -- particularly if it is a lengthy document. Once loaded,
the first thing you will see is an opening menu for Adobe
Acrobat.

The next thing you will see is the document itself. Here is the first page from the first
lecture for this course: .
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. There are several buttons that will help you navigate around an Adobe Acrobat
document. Here are the functions for the buttons at the topic of the menu:

i File Edit Uiew Tools Window

[[[ e | = » ol |3 &4
Mo

Goes back ope
page. Word search.
Highlights text
Goes to\gnd
/ Ams out. of documgnt.
ves the page vertically and
horizontally. Goes forward Flips back and forth

Goes to beginning e .
Z00ms in. Shifts viewing perspective.
Shows indices and thumbnails if available. one page. between viewed pages.

of document.

[ULTIT Tools Window

Actual Size 3#H
Fit Page A
Fit Width 3K
Fit Disible
Full Screen

. You can also get a full-screen image by using the
“View” button at the top of the menu bar.

. There are some functions for the buttons at the bottom of the menu:

1 of 2 L 86% w| [M 11.00 x 850 in

!

Changes zoom

Changes page location Shows page size
in document. and orientation.

(Al Edit Diew Tool
*  When you are finished reading an Adobe Acrobat Open... %0

document, you should Quit the program (rather than just Close W
close it) and you will go back to Netscape. Document Info  p

Page Setup... 4P
Print... P
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Additional Information

If you are ever in a lab and have trouble accessing a pdf document from within
Netscape, you should first ask for help from a lab assistant. Then, please let me know
about the problem.

In some instances you may get a message asking you to save the document to disk.
In this case, you can first save the file to the harddrive or a floppy, then exit Netscape,
and then start Adobe Acrobat. From within Adobe Acrobat, you can open the lecture
that you saved. If you save the file to the harddrive, ERASE THE LECTURE FROM
THE HARDDRIVE WHEN YOU ARE FINISHED! It is not a good idea for us to clutter
up the lab computers with these lecture materials. If you save the file to a floppy disk,
you may use it as you please. However, be forewarned that these files take up lots of
space.
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Using Eudora

. Eudora is a software program that allows you to send, receive and store e-mail.
. You must have an activated PID to use Eudora.
. To use Eudora on campus, you should obtain a copy of Eudora for Lab Use.

Getting Started with Eudorain a Lab

. Go to the Networking page of the launcher.

Insert your Eudora floppy disk.

Click “Eudora” on the launcher and then click “Find Settings”.

(Note: Don't click “Eudora Settings” from the launcher -- this will load a new version of
Eudora to your floppy disk.)

Move from “Networking f” to “Desktop”. Find your disk and click “Open”.

Highlight “Eudora Folder” and click “Open.” Highlight “Eudora
Settings” and click “Open”. Eudara Settings

The Eudora menu should then appear across the top of the screen.

ﬁ File Edit Mailbox Message Transfer Special Window

First Time Use Only: Configuration
Remoie Aec | ]

. From the Special menu, pull down Settings. |, rf....“
Compaci Pl
:.hnnﬂ.n Password...

. Highlight the Getting Started option, and type your information in the spaces provided.

— NOTE: To change text, you should highlight old text and retype rather than use
the backspace or delete keys.

— POP Account: your-pid@mail.vt.edu
— Real Name: your name - w.m:.r:.mqs
— Connection Method: MacTCP LR | e it
Ceaitirg Edwind |uI| T T |
ﬁ;:i hT;I:-r:m-mmu- |
Paraaral siormastiis Connsoting Hetfad
T & P TCF
L ) Commuunications Teclbax
s e [ (8717 & s nsl
(&l
kg sl E
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. Highlight the Personal Information option, and type your information in the spaces
provided. (Some information will be entered already.)
— NOTE: To change text, you should highlight old text and retype rather than use
the backspace or delete keys.

— POP Account: your-pid@mail.vt.edu
— Real Name: your name
— Return Address: your-pid@vt.edu (note: NOT mail.vt.edu)
Anilings
i fIEE"
e e '
Fa E-;Mu ¥ s lﬂlm !
[darvee |
uig: |lI|llHrﬁ'\l|Iﬂr |
B
- (o ()

. Highlight the Hosts option, and type your information in the spaces provided. (Some
information will already be entered.) When finished, click OK.

— NOTE: To change text, you should highlight old text and retype rather than use
the backspace or delete keys.

— POP Account: your-pid@mail.vt.edu
-  SMTP: mail.vt.edu
-  Ph: ns.vt.edu
haltings
W™ |
2 SHIP:  [anistadd ]
e e i P [ et ks |
4 . | !
s 0 05 o el i
B
[ roee] ()

Changing Your Password I window |
. Before you can use your PID for the first time, you must change your | e =
password. Add as Recipient

. . . Remove Recipient P
. You should periodically change your password for security purposes. ———
. . . . mpty Iras
. If your password remains unchanged for 90 days, it will expire and Compact Mailboxes
you will be prompted to change it before you can continue to use your Settings...
PID. Communications...
. To change your password, first select Change Password from the Forget Password
Special menu. Change Password... .

©1996 Mary Beth Oliver



Enter your current password on in the space provided and

click OK.

Enter your your new password in the space provided and

click OK.

You will be asked to verify your password by retyping it.

After your new password is accepted, you will receive the

following message: (Click OK)

Sending Mail
You are now ready to send mail. To test your configuration, you should send

yourself an e-mail message.
Select New Message from the Message menu.

Type your e-mail address (PID) in the To: field.
Type a subject in the Subject: field.

Type a message.

Click Send. (If prompted, enter your password.)

m. v Apek

200 0k gk imeaad Changed

|

i Pelich ool T L]

SH=——— olivermbauvt.edu, new message HE
EIM : T e
REEE: B 2
To: olivermb@ut, edy <
From: olivermnb@ut. edo (Mary Beth OLiver) I
Sub ject: new meszage
Ci:
Bco:
Attachments:
Here is my first message.
Maty
il
e
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Receiving Mail o e et

EESN o mailhon ey

Select Check Mail from the File menu. (If prompted, enter
your password.)

One of two symbols will appear. Click OK. AT —

Fage Saiep
Kl - 12K oS- Print sectia
"H. - uit L5}
= G = | I |

If you have new mail, you can click a highlighted message in the In mail window. The
little dot in the left column indicates a message that has not yet been read.

S In=———— ]I
. Mary Beth Oliver 3:18 PM 2/31/95 - 1 new message ﬁ

]
1 /B BK ] B

Here is how the new message will appear. If you would like to close the message
without transferring it or deleting it, click the small box in the upper-left corner.

C—— Mary Beth Dliver,3:10 PM 7/31/95 -0,new message =——H=

ELAH
ELM Subject: new message

Date: Mow, 31 Jul 1935 15:18:25 -B6488 4
H-Sender: olivermb@mail . wi. edu ]
Himz—lersion: 1.8

To: olivermbEwt. edu

From: olivermb@ut. eduy {Mary Beth OLiver)
Subject: new message

Here is my first message.

Mary

ElE

If you would like to delete the message, first select Trash from the Transfer menu, and
then select Empty Trash from the Special menu.

Spec:ial Window _

Make Mickname... #K

Transfer

-> Trash .

Add as Recipient
Remove Recipient #

_EmptyTrash |

Compact Mailboxes

NBLr ., settings...

Communications...

Forget Password
Change Password...
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Creating Nicknames

. Because e-mail addresses are often long and hard to remember, you may consider
creating nicknames for frequently used addresses.

. First select Nicknames from the Window menu, and then select New from the
Nicknames window.

] e KN T -]
IWindow Rt KT Ridressias
Nicknames | #L
Ph U
Signature TR
Send to Back %B 3
(preme) vew | I |
—— L3 I i

. Type in what you would like to call your nickname, and then click OK. Note:
Spaces are not allowed.

. In the next menu, type in the address of the nickname. When finished, you can
close the window by clicking in the small box in the upper left-hand corner. You will
be asked to save your changes.

] e KN T -]
Wl Kniam N resanas
= b | sl b i
What do you wish to call it?
|mhc4 |
[ Put it on the recipient list
= ek
| B || e
—— T [ [ 1l [T |

7|

. To send a message to an address with a nickname, simply type in the nickname in the
To: field.

Using Mailboxes

. Mailboxes allow you to efficiently organize your e-mail messages. You automatically
have 3 mailboxes: In (which is where your new messages go), Out (which is where your
sent messages go if you keep copies), and Trash.

. To create a new mailbox, select Mailboxes from the Window menu, then type in the
name of your new mailbox and click OK.

Window

. [lﬂlﬂ i Wil G Eoleas Foldar.
MailboHes |

Nicknames L P niame the neiw mallbod:

Ph U | Communicsises Beiearcs

Signature [CI*dake i1 a Enlder

Send to Back #*B Ea [Camtol | [ ik ;]
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Now, after reading a message, you have the option of S Special Window
transferring the message to your new mailbox by -» Trash

selecting your mailbox from the transfer menu.

NEL. ..
-» Communication Research .|

To view the messages that you have transferred to Message Transfe

mailboxes, you can select the mailbox from the In #l
Mailbox menu. You can also always transfer T“;‘;sh
messages to the Trash mailbox and empty the trash

to delete unwanted messages.

Communication Besearch

Using Signature Files

Signature files are texts that are appended to the end of e-mail messages. Many people
include their name, address, and other pertinent information in their signature file so
they don’t have to type the information each time they send an e-mail.

To create a signature file, select Signature from the Windows menu. Then type in the
signature that you would like to be attached to e-mail you send.

Close the signature window by clicking in the small upper left-hand box.

| window [ T
Mailboxes '
MNicknames 3L

Ph U

Signature

Send to Back B

To attach your signature, click the John Hancock symbol

before you send a message. = olluarmh et i, s ~
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[
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Fare’s  reermge beime |

Quitting Eudora

To quit Eudora, select Quit from the File menu. Then drag your disk to the trash icon to
ejectit. NOTE: Don't use the “eject disk” option.
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